Home arrow News Archive arrow Easy v2.00/2.01 Downgrader
Easy v2.00/2.01 Downgrader
Written by Administrator    Saturday, 09 September 2006
Image A long time ago, when the GTA exploit first emerged, the first application we wrote for it was a v2.01 downgrader, similar to MPH's downgrader for v2.00. Unfortunately, the GTA exploit didn't offer sufficient access to the PSP's flash to allow the downgrader to work, so it was never released.

The new TIFF exploit allows us the necessary access, and so here it is, after some thorough testing on our own PSPs - an easy downgrader for firmware v2.00 and v2.01, via eLoader 0.9.8.
The advantage of this downgrader is that it doesn't require a firmware dump from a v1.5 PSP. It also contains a lot of extra safety checks and user friendliness enhancements, as well as a safer method for overwriting the INDEX.DAT file.

Many v2.0 and v2.01 users who wanted to downgrade may already have used the v2.6 or v2.71 Downdaters, so the usefulness of this downgrader is perhaps limited. But we're releasing it now so that anyone who might find it useful can use it.

Please ensure that you read the entire README.TXT file that is included with the downgrader package. Please also note that although this uses tried and tested techniques, and has been tested with 100% success on several PSPs, no downgrader is 100% safe, and so YOU USE THIS SOFTWARE AT YOUR OWN RISK.

You can download it by clicking here.

Comments (9)add comment

A noobz lover said:

  I've used this downgrader to downgrade my brandnew 2.01 PSP. It is very noobproof and easy to use.
Thanks to the noobz team, I have homebrew now smilies/grin.gif
December 29, 2006

fandango said:

  THanks Guys! this is the only and the best downgrader around!
January 08, 2007

iq0099 said:

  does it work with 1007 models?
January 16, 2007

Pauly73 said:

  IM SCARED I WILL BRICK MY PSP, SUM1 GIV ME THE CONFIDENCE TO DO IT PLZ, lol. Nah it should be ok, I will give it a go right now.
September 04, 2007

Ripsnort said:

  Thanks alot for this fellas! This is exactly what i needed for my v2.01
October 03, 2007

afasfrewaf said:

  hmmm, what version do you downgrade to?
November 29, 2007

dlf;akjf said:

  I tried putting the downgrader on my psp but when i try to play it all it says is corrupted data help plz
February 14, 2008

Blake said:

  i tried to download this onto my psp but when i try to play it all it says is corrupted dat help plz
February 14, 2008

boyaka said:

  where to put it?
April 10, 2008

Write comment
quote
bold
italicize
underline
strike
url
image
quote
quote
Smiley
Smiley
Smiley
Smiley
Smiley
Smiley
Smiley
Smiley
Smiley
Smiley
Smiley
Smiley

security image
Write the displayed characters


busy
 
< Prev   Next >
If you have found this site or software useful, please consider donating a small amount of money using the button below.

Login Form






Lost Password?
© 2019 N00bz!
This web page is licenced for your personal, private, non-commercial use only.
RIPA NOTICE: NO CONSENT IS GIVEN FOR INTERCEPTION OF PAGE TRANSMISSION
Joomla! is Free Software released under the GNU/GPL License.